今天给一个客户安装dedecms的时候,安装完成后登录后台,出现如下提示:
 
按常规步骤:web文件复制过去,数据库用phpmyadmin导出导入过去,修改“data/common.inc.php”里面的数据库信息。
 
打开首页正常,登录后台的时候直接提示“Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in**********”,如下图:

翻译报错信息和搜索后得出结果,php7以上版本不支持用“function __autoload(){}”,所以才会报这个错误。
 
解决办法也很简单,把php版本降低一点就行了,5.6和5.4都行。

发表评论

后才能评论